36
Vote

VS2012 deploy and code stepping is very slow

description

Upgrading from VS2010 to VS2012, we noticed that deploying is very slow, which can be worked around but then stepping in code is very slow as well.

First, we thought it maybe the device but it is very slow even in the emulator. This machine we tested, is i7 processor with 12MB of RAM. This also seem the case for many who have reported on our forums.

Maybe votes and replies will show us if other users are or aren't noticing this behavior.

Please revisit debugging to see what can be done to speed up the debugging features. We are ready to run any tests and provide any help as necessary.

Thanks

Gus - GHI electronics

comments

NJ08512 wrote May 1, 2013 at 4:12 PM

I have also seen this slowdown with VS2012!

TechInfo wrote May 1, 2013 at 5:15 PM

Have this problem too using Netduino Plus 2 on Windows 8 x64 and VS 2012

gus_ghielec wrote May 1, 2013 at 5:52 PM

To be clear, I am referring to it being slow when using NETMF.

gus_ghielec wrote May 1, 2013 at 8:42 PM

WeegieBoy wrote May 8, 2013 at 5:03 PM

Using Windows 7 64 bit and VS2012 Express for NETMF and slow here too.

Ferlaa wrote Jun 17, 2013 at 12:57 PM

Same as WeegieBoy except using VS2012 Ultimate

AndreMarschalek wrote Jun 17, 2013 at 1:32 PM

to manually change the driver to winusb (C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb) solved my speed problem

JohnySeven wrote Jun 20, 2013 at 8:17 AM

I can confirm that debuging NETMF program with VS 2012 is very slow, mostly when using watch functions or immediate window.

Hieber wrote Jul 6, 2013 at 9:26 PM

I can confirm the Problem too.
Manually changing the driver to winusb (C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb) solved my speed Problem in VS 2012

gismo wrote Mar 24 at 7:27 PM

It's noticeably slower than VS2010! In fact, it was the first thing I noticed!

_Elias_ wrote Jul 4 at 8:57 PM

Same problem here, Windows 7 64 bit